<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
	<head>
		<meta charset="UTF-8">
		<meta name="google-site-verification" content="xkrJ0rSk8sSEq92tIV4hBiMQPSKheVMadhUWwCCTdIE" />
		<title>New snow plow moves more snow, faster and with more control</title>
		
<link rel="shortcut icon" href="https://www.turfmagazine.com/wp-content/uploads/2015/02/turf_favicon.jpg" />

		<!-- Default Meta Tags -->
		<meta charset="UTF-8">

<link href="//www.google-analytics.com" rel="dns-prefetch">

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes">

<meta name="description" content="">
		




<link rel="pingback" href="https://www.turfmagazine.com/xmlrpc.php" />

		<!-- Facebook integration -->
  

<meta property="og:site_name" content="Turf">

<meta property="og:url" content="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/"/>  
<meta property="og:type" content="article" />
<meta property="og:title" content="Meyer Products Super-V3 Snow Plow" />  
<meta property="og:description" content="The all-new Meyer® Super-V3&#x2122; snow plow from Meyer Products is made for ¾ ton and larger trucks and comes with a five year warranty. It ...">
	<meta property="og:image" content="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg" />



		<!-- css + javascript -->
		<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary">
<!-- [(-_-)@ Missing critical option ! @(-_-)] -->
<!-- [(-_-)@ Missing critical option ! @(-_-)] -->
<meta name="twitter:title" content="Meyer Products Super-V3 Snow Plow">
<meta name="twitter:description" content="The all-new Meyer® Super-V3&#x2122; snow plow from Meyer Products is made for ¾ ton and larger trucks and comes with a five year warranty. It is engineered with features designed to move more snow,">
<meta name="twitter:image" content="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
                        <script>
                            /* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Oswald:300,400,700', 'Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();
                        </script>
                        
<!-- This site is optimized with the Yoast SEO plugin v9.5 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The Meyer Super-V3 snow plow is for ¾ ton and larger trucks and moves more snow, faster, with V, scoop, and straight blade configuration options."/>
<link rel="canonical" href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="New snow plow moves more snow, faster and with more control" />
<meta property="og:description" content="The Meyer Super-V3 snow plow is for ¾ ton and larger trucks and moves more snow, faster, with V, scoop, and straight blade configuration options." />
<meta property="og:url" content="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" />
<meta property="og:site_name" content="Turf" />
<meta property="article:tag" content="Meyer Products" />
<meta property="article:tag" content="Plow" />
<meta property="article:tag" content="plow forwards and backwards" />
<meta property="article:tag" content="plow snow" />
<meta property="article:tag" content="remove snow" />
<meta property="article:tag" content="snow removal" />
<meta property="article:tag" content="Super-V3" />
<meta property="article:tag" content="v-plow" />
<meta property="article:section" content="Snow &amp; Ice Management" />
<meta property="article:published_time" content="2019-03-12T06:00:55+00:00" />
<meta property="article:modified_time" content="2019-03-08T15:39:10+00:00" />
<meta property="og:updated_time" content="2019-03-08T15:39:10+00:00" />
<meta property="og:image" content="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg" />
<meta property="og:image:secure_url" content="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg" />
<meta property="og:image:width" content="780" />
<meta property="og:image:height" content="510" />
<meta property="og:image:alt" content="snow plow" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Turf &raquo; Feed" href="https://www.turfmagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Turf &raquo; Comments Feed" href="https://www.turfmagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Turf &raquo; Meyer Products Super-V3 Snow Plow Comments Feed" href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.turfmagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='selection-sharer-css'  href='https://www.turfmagazine.com/wp-content/plugins/selection-sharer/css/selection-sharer.css?ver=0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tptn-style-left-thumbs-css'  href='https://www.turfmagazine.com/wp-content/plugins/top-10/css/default-style.css?ver=4.9.9' type='text/css' media='all' />
<style id='tptn-style-left-thumbs-inline-css' type='text/css'>

img.tptn_thumb {
  width: 85px !important;
  height: 85px !important;
}
                

			.tptn_posts_widget3 img.tptn_thumb {
				width: 85px !important;
				height: 85px !important;
			}
			

			.tptn_posts_widget4 img.tptn_thumb {
				width: 85px !important;
				height: 85px !important;
			}
			
</style>
<link rel='stylesheet' id='testimonial-rotator-style-css'  href='https://www.turfmagazine.com/wp-content/plugins/testimonial-rotator/testimonial-rotator-style.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/latest/css/font-awesome.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-flexslider-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/flexslider/flexslider-custom.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-social-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/social-icons/css/zocial.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-entypo-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/entypo/css/entypo.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-symbol-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/font-icons/symbol/css/symbol.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-swipebox-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/swipebox/swipebox.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-bootstrap-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/bootstrap/css/bootstrap.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-theme-css'  href='https://www.turfmagazine.com/wp-content/themes/presso2-0/css/theme.css?ver=1.1%20tacOcat' type='text/css' media='all' />
<link rel='stylesheet' id='childe-style-css'  href='https://www.turfmagazine.com/wp-content/themes/tacocat/style.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='ebsco-gallery-frontend-css'  href='https://www.turfmagazine.com/wp-content/themes/tacocat/css/gallery-frontend.css?ver=4.9.9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/www.turfmagazine.com\/wp-admin\/admin-ajax.php","top_ten_id":"95084","top_ten_blog_id":"1","activate_counter":"11","tptn_rnd":"556834115"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/top-10/includes/js/top-10-tracker.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/testimonial-rotator/js/jquery.cycletwo.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/testimonial-rotator/js/jquery.cycletwo.addons.js?ver=4.9.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var instant_search = {"blog_url":"https:\/\/www.turfmagazine.com","ajax_url":"https:\/\/www.turfmagazine.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/instant-search/instant-search.js?ver=1.1%20tacOcat'></script>
<link rel='https://api.w.org/' href='https://www.turfmagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.turfmagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.turfmagazine.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.9" />
<link rel='shortlink' href='https://www.turfmagazine.com/?p=95084' />
<link rel="alternate" type="application/json+oembed" href="https://www.turfmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.turfmagazine.com%2Fsnow-ice-management%2Fmeyer-products-super-v3-snow-plow%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.turfmagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.turfmagazine.com%2Fsnow-ice-management%2Fmeyer-products-super-v3-snow-plow%2F&#038;format=xml" />
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>	<style type="text/css" id="custom-background-css">
	body.custom-background.site-layout-boxed
	, body.custom-background.site-layout-full-large #off-canvas-body-inner
	, body.custom-background.site-layout-full-medium #off-canvas-body-inner
	{ background-image: url('https://www.turfmagazine.com/wp-content/uploads/2016/06/TURF-website-background.jpg'); background-repeat: no-repeat; background-position: top center; background-attachment: fixed; }
	</style>
			<style id="vw-custom-font" type="text/css">
						
					</style>
			<!-- Theme's Custom CSS -->
	<style type="text/css">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</style>
	<style type="text/css" title="dynamic-css" class="options-output">h1, h2, h3, h4, h5, h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:normal;color:#333333;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6,{visibility: hidden;}body{font-family:"Open Sans";font-weight:400;font-style:normal;color:#666666;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading body,{opacity: 0;}.ie.wf-loading body,{visibility: hidden;}</style>

<script type="text/javascript">
(function() {
  var didInit = false;
  function initMunchkin() {
    if(didInit === false) {
      didInit = true;
      Munchkin.init('342-MMW-280');
    }
  }
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//munchkin.marketo.net/munchkin-beta.js';
  s.onreadystatechange = function() {
    if (this.readyState == 'complete' || this.readyState == 'loaded') {
      initMunchkin();
    }
  };
  s.onload = initMunchkin;
  document.getElementsByTagName('head')[0].appendChild(s);
})();
</script>

<!-- RTP tag --> 
<script type='text/javascript'>
(function(c,h,a,f,i,e){c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
 c[a].a=i;c[a].e=e;var g=h.createElement("script");g.async=true;g.type="text/javascript";
 g.src=f+'?aid='+i;var b=h.getElementsByTagName("script")[0];b.parentNode.insertBefore(g,b);
 })(window,document,"rtp","//abrtp1-cdn.marketo.com/rtp-api/v1/rtp.js","turfmagazine");
 
rtp('send','view');
rtp('get', 'campaign',true);
</script>
<!-- End of RTP tag -->



<script>
var dfp_adDisplay_js = "/11506265/";
</script>

<!-- Begin DFP Header Code -->

<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
var gptAdSlots = [];
googletag.cmd.push(function() {

var TFAboveFooter = googletag.sizeMapping().
addSize([320, 1], [[1, 1], [320, 50], [300, 50], [300, 100]]).
addSize([728, 1], [[1, 1], [728, 90]]).
addSize([970, 1], [[1, 1], [970, 90], [970, 250], [728, 90]]).
build();
window.slot0 = googletag.defineSlot("/11506265/TF-AboveFooter", [320, 50],
 "div-gpt-ad-1467129242315-0").defineSizeMapping(TFAboveFooter).addService(googletag.pubads());

var TFAboveHeader = googletag.sizeMapping().
addSize([320, 1], [[1, 1], [320, 50], [300, 50], [300, 100]]).
addSize([728, 1], [[1, 1], [728, 90]]).
addSize([970, 1], [[1, 1], [970, 90], [970, 250], [728, 90]]).
build();
window.slot1 = googletag.defineSlot("/11506265/TF-AboveHeader", [320, 50],
 "div-gpt-ad-1467129242315-1").defineSizeMapping(TFAboveHeader).addService(googletag.pubads());

window.slot3 = googletag.defineSlot("/11506265/TF-Brandscape", [1, 1],
 "div-gpt-ad-1467129242315-3").addService(googletag.pubads());

var TFHeader = googletag.sizeMapping().
addSize([320, 1], [[1, 1], [320, 50], [300, 50], [300, 100]]).
addSize([728, 1], [[1, 1], [728, 90]]).
addSize([970, 1], [[1, 1], [728, 90]]).
build();
window.slot4 = googletag.defineSlot("/11506265/TF-Header", [320, 50],
 "div-gpt-ad-1467129242315-4").defineSizeMapping(TFHeader).addService(googletag.pubads());

var TFRight1 = googletag.sizeMapping().
 addSize([320, 1], [[1, 1], [300, 250]]).
addSize([728, 1], [[1, 1], [300, 250], [300, 600], [300, 1050], [160, 600]]).
addSize([970, 1], [[1, 1], [300, 250], [300, 600], [300, 1050], [160, 600]]).
build();
window.slot5 = googletag.defineSlot("/11506265/TF-Right1", [300, 250],
 "div-gpt-ad-1467129242315-5").defineSizeMapping(TFRight1).addService(googletag.pubads());

var TFRight2 = googletag.sizeMapping().
addSize([320, 1], [[1, 1], [300, 250]]).
addSize([728, 1], [[1, 1], [300, 250], [300, 600], [160, 600]]).
addSize([970, 1], [[1, 1], [300, 250], [300, 600], [160, 600]]).
build();
window.slot6 = googletag.defineSlot("/11506265/TF-Right2", [300, 250],
 "div-gpt-ad-1467129242315-6").defineSizeMapping(TFRight2).addService(googletag.pubads());

var TFRight3 = googletag.sizeMapping().
        addSize([320, 1], [[1, 1], [300, 250]]).
        addSize([728, 1], [[1, 1], [300, 250]]).
        addSize([970, 1], [[1, 1], [300, 250]]).
        build();
window.slot7 = googletag.defineSlot("/11506265/TF-Right3", [300, 250],
 "div-gpt-ad-1467129242315-7").defineSizeMapping(TFRight3).addService(googletag.pubads());

var TFRight4 = googletag.sizeMapping().
 addSize([320, 1], [[1, 1], [300, 250]]).
 addSize([728, 1], [[1, 1], [300, 250]]).
 addSize([970, 1], [[1, 1], [300, 250]]).
 build();
window.slot8 = googletag.defineSlot("/11506265/TF-Right4", [300, 250],
 "div-gpt-ad-1467129242315-8").defineSizeMapping(TFRight4).addService(googletag.pubads());

window.slot9 = googletag.defineSlot("/11506265/TF-Interstitial", [1, 1],
 "div-gpt-ad-1467129242315-9").addService(googletag.pubads());

window.slot14 = googletag.defineSlot("/11506265/TF-MobileAdhesion", [1, 1],
 "div-gpt-ad-1467129242315-14").addService(googletag.pubads());

window.slot15 = googletag.defineSlot("/11506265/TF-SuperscapePlaceholder", [1, 1],
 "div-gpt-ad-1467129242315-15").addService(googletag.pubads());

googletag.pubads().setTargeting("category",["maintenance","products","snow-ice-management"]);
googletag.pubads().setTargeting("tag",["meyer-products","plow","plow-forwards-and-backwards","plow-snow","remove-snow","snow-removal","super-v3","v-plow",]);
googletag.pubads().setTargeting("page",["95084"]);
googletag.pubads().collapseEmptyDivs(true);
googletag.pubads().enableSingleRequest();
googletag.enableServices();
  });
</script>
<!-- Google Analytics Custom Reporting Script 120916 Turf UA-120631451-2 --> 

<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-120631451-2', 'auto');
  ga('send', 'pageview', {
  'dimension1': '|maintenance|products|snow-ice-management|',
  'dimension2': '|meyer-products|plow|plow-forwards-and-backwards|plow-snow|remove-snow|snow-removal|super-v3|v-plow|'
});
</script>
<!-- end script -->
<script>
(function() {
var d=document,h=d.getElementsByTagName('head')[0],s=d.createElement('script'),sc = 'https:' == document.location.protocol ? 'https://' : 'http://';
s.type='text/javascript';
s.async=true;
s.src=sc+'s.dpmsrv.com/dpm_a2e33d344f272e100d4a8efeabc7ae8a60a8ba7a.min.js';
h.appendChild(s);
})();
</script>


	</head>
	<body id="top" class="post-template-default single single-post postid-95084 single-format-standard custom-background site-layout-boxed site-enable-post-box-effects">

<br> 
<!-- /11506265/TF-AboveHeader -->
<center>
<div id="div-gpt-ad-1467129242315-1">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-1");
});
</script>
</div>
</center>

			<nav id="mobile-nav-wrapper"></nav>
			<div id="off-canvas-body-inner">

				<!-- Top Bar -->
				<div id="top-bar" class="top-bar">
					<div class="container">
						<div class="row">
							<div class="col-sm-12">
								<div class="top-bar-right">

									
									<a class="site-social-icon" href="https://www.facebook.com/TurfMagazine" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://twitter.com/TurfMagazine" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a>
									<a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a>
								</div>

								<a id="open-mobile-nav" href="#mobile-nav" title="Search"><i class="icon-entypo-menu"></i></a>
								
								<nav id="top-nav-wrapper">
								<ul id="menu-header" class="top-nav list-unstyled clearfix"><li id="nav-menu-item-318" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a target="_blank" href="https://www.turfmagazine.com/subscribe" class="menu-link main-menu-link"><span>Subscribe</span></a>
<ul class="sub-menu menu-odd  menu-depth-1">
	<li id="nav-menu-item-94602" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.cdsreportnow.com/renew/now?trf" class="menu-link sub-menu-link"><span>Magazine</span></a></li>
	<li id="nav-menu-item-34651" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://editor.ne16.com/Subscribe/Form.ashx?l=1002941&amp;p=d6d79324-ae7e-4dfc-a208-4088d557bb70" class="menu-link sub-menu-link"><span>Newsletter</span></a></li>
</ul>
</li>
<li id="nav-menu-item-532" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.turfmagazine.com/reprints/" class="menu-link main-menu-link"><span>Reprints</span></a></li>
<li id="nav-menu-item-665" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.turfmagazine.com/about-us/" class="menu-link main-menu-link"><span>About Us</span></a></li>
<li id="nav-menu-item-94417" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.turfmagazine.com/advertise-with-us/" class="menu-link main-menu-link"><span>Advertise with us</span></a></li>
<li id="nav-menu-item-477" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.turfmagazine.com/contact-us/" class="menu-link main-menu-link"><span>Contact Us</span></a></li>
</ul>								</nav>
								
							</div>
						</div>
					</div>
				</div>
				<!-- End Top Bar -->
				
				<!-- Main Bar -->
								<header class="main-bar header-layout-left-logo">
					<div class="container">
						<div class="row">
							<div class="col-sm-12">
								<div id="logo" class="">
									<a href="https://www.turfmagazine.com/">
																		
																														<img src="https://www.turfmagazine.com/wp-content/uploads/2016/09/turf-logo-2016-406x180.png" width="203" height="90" alt="Turf" class="logo-retina" />
																				<img src="https://www.turfmagazine.com/wp-content/uploads/2016/09/turf-logo-2016-203x90.png" width="203" height="90" alt="Turf" class="logo-original" />

																		
																		</a>
								</div>
							
																<div class="header-ads">
									<!-- /24055536/TF-Header -->
<div id="div-gpt-ad-1467129242315-4" >
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-4");
});
</script>
</div>								</div>
																
							</div>
						</div>
					</div>
				</header>
				<!-- End Main Bar -->

				<!-- Main Navigation Bar -->
				<div class="main-nav-bar header-layout-left-logo">
					<div class="container">
						<div class="row">
							<div class="col-sm-12">
								<nav id="main-nav-wrapper"><ul id="menu-main" class="main-nav list-unstyled"><li id="nav-menu-item-8079" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.turfmagazine.com/category/business-management/" class="menu-link main-menu-link"><span>Business Management</span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
	<li id="nav-menu-item-8091" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/industry-news/" class="menu-link sub-menu-link"><span>Industry News</span></a></li>
	<li id="nav-menu-item-8088" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/resources/" class="menu-link sub-menu-link"><span>Resources</span></a></li>
</ul>
					<ul class="sub-posts">
						<li class="col-sm-4"><article class="post-95095 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="Turf Spring 2019 Issue" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">Turf Spring 2019 Issue: Time For Renewal</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/anne-cosgrove/" title="View all posts by Anne Cosgrove">Anne Cosgrove</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" class="post-date" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">March 11, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-95080 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/business-management/lawnsite-forums-this-weeks-hot-threads-march-5-2019/" title="Permalink to LawnSite Forums: This Week’s Hot Threads" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2018/07/lawnsite_logo_bckgrnd_x770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="landscape professionals" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/07/lawnsite_logo_bckgrnd_x770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2018/07/lawnsite_logo_bckgrnd_x770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/business-management/lawnsite-forums-this-weeks-hot-threads-march-5-2019/" title="Permalink to LawnSite Forums: This Week’s Hot Threads" rel="bookmark">LawnSite Forums: This Week’s Hot Threads</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/mary-ellen-mccandless/" title="View all posts by Mary Ellen McCandless">Mary Ellen McCandless</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/business-management/lawnsite-forums-this-weeks-hot-threads-march-5-2019/" class="post-date" title="Permalink to LawnSite Forums: This Week’s Hot Threads" rel="bookmark">March 5, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-95075 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow management professionals" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">Plowsite: This Week’s Cool Threads</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/mary-ellen-mccandless/" title="View all posts by Mary Ellen McCandless">Mary Ellen McCandless</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" class="post-date" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">March 5, 2019</a>
		</div>
	</div>

</article></li>					</ul>

				</div>
</li>
<li id="nav-menu-item-8067" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.turfmagazine.com/category/services/" class="menu-link main-menu-link"><span>Services</span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
	<li id="nav-menu-item-8075" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.turfmagazine.com/category/maintenance/" class="menu-link sub-menu-link"><span>Maintenance</span></a></li>
	<li id="nav-menu-item-8074" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/lawn-care/" class="menu-link sub-menu-link"><span>Lawn Care</span></a></li>
	<li id="nav-menu-item-8072" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/landscape-designbuildinstallation/" class="menu-link sub-menu-link"><span>Design/Build/Installation</span></a></li>
	<li id="nav-menu-item-78899" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/tree-care/" class="menu-link sub-menu-link"><span>Tree Care</span></a></li>
	<li id="nav-menu-item-8070" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/hardscapes/" class="menu-link sub-menu-link"><span>Hardscapes</span></a></li>
	<li id="nav-menu-item-8076" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.turfmagazine.com/category/snow-ice-management/" class="menu-link sub-menu-link"><span>Snow &#038; Ice Management</span></a></li>
	<li id="nav-menu-item-8086" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/irrigation/" class="menu-link sub-menu-link"><span>Irrigation</span></a></li>
</ul>
					<ul class="sub-posts">
						<li class="col-sm-4"><article class="post-95002 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/industry-news/bartlett-tree-experts-expands-to-140-locations/" title="Permalink to Bartlett Tree Experts Expands To 140 Locations" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/02/bartlett_tree_locations-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="tree care" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/02/bartlett_tree_locations-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/02/bartlett_tree_locations-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/industry-news/bartlett-tree-experts-expands-to-140-locations/" title="Permalink to Bartlett Tree Experts Expands To 140 Locations" rel="bookmark">Bartlett Tree Experts Expands To 140 Locations</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/anne-cosgrove/" title="View all posts by Anne Cosgrove">Anne Cosgrove</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/industry-news/bartlett-tree-experts-expands-to-140-locations/" class="post-date" title="Permalink to Bartlett Tree Experts Expands To 140 Locations" rel="bookmark">February 20, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-94949 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/irrigation-installation-andor-maintenance/in-2018-conserva-irrigation-grows-franchise-network/" title="Permalink to In 2018, Conserva Irrigation Grows Franchise Network" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/02/conserva_irrigation_2019-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="outdoor irrigation" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/02/conserva_irrigation_2019-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/02/conserva_irrigation_2019-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/irrigation-installation-andor-maintenance/in-2018-conserva-irrigation-grows-franchise-network/" title="Permalink to In 2018, Conserva Irrigation Grows Franchise Network" rel="bookmark">In 2018, Conserva Irrigation Grows Franchise Network</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/anne-cosgrove/" title="View all posts by Anne Cosgrove">Anne Cosgrove</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/irrigation-installation-andor-maintenance/in-2018-conserva-irrigation-grows-franchise-network/" class="post-date" title="Permalink to In 2018, Conserva Irrigation Grows Franchise Network" rel="bookmark">February 11, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-94836 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/the-latest/the-invasive-spotted-lanternfly-know-what-to-do/" title="Permalink to The Invasive Spotted Lanternfly: Know What To Do" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/01/spotted_lanternfly_PA-360x200.png" class="attachment-vw_small size-vw_small wp-post-image" alt="spotted lanternfly" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/01/spotted_lanternfly_PA-360x200.png 360w, https://www.turfmagazine.com/wp-content/uploads/2019/01/spotted_lanternfly_PA-265x147.png 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/the-latest/the-invasive-spotted-lanternfly-know-what-to-do/" title="Permalink to The Invasive Spotted Lanternfly: Know What To Do" rel="bookmark">The Invasive Spotted Lanternfly: Know What To Do</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/e0cb2d5db565d00dc94117a808cbc578?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e0cb2d5db565d00dc94117a808cbc578?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/gclawnguest1/" title="View all posts by Guest Contributor">Guest Contributor</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/the-latest/the-invasive-spotted-lanternfly-know-what-to-do/" class="post-date" title="Permalink to The Invasive Spotted Lanternfly: Know What To Do" rel="bookmark">January 24, 2019</a>
		</div>
	</div>

</article></li>					</ul>

				</div>
</li>
<li id="nav-menu-item-36394" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.turfmagazine.com/category/nurseryplant-materials/" class="menu-link main-menu-link"><span>Plants</span></a><div class="sub-menu-container">					<ul class="sub-posts">
						<li class="col-sm-4"><article class="post-95095 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="Turf Spring 2019 Issue" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">Turf Spring 2019 Issue: Time For Renewal</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/anne-cosgrove/" title="View all posts by Anne Cosgrove">Anne Cosgrove</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" class="post-date" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">March 11, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-95059 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/lawn-care/21-0-dr-wood-chipper-shredder/" title="Permalink to 21.0 DR Wood Chipper Shredder" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/DR-Wood-21.0-Chipper-Shredder-feat-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="chipper shredder" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/DR-Wood-21.0-Chipper-Shredder-feat-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/DR-Wood-21.0-Chipper-Shredder-feat-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/lawn-care/21-0-dr-wood-chipper-shredder/" title="Permalink to 21.0 DR Wood Chipper Shredder" rel="bookmark">21.0 DR Wood Chipper Shredder</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/dcantelmegroupc-com/" title="View all posts by Dominique Cantelme">Dominique Cantelme</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/lawn-care/21-0-dr-wood-chipper-shredder/" class="post-date" title="Permalink to 21.0 DR Wood Chipper Shredder" rel="bookmark">March 7, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-94967 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/general-turf-care/improve-performance-new-turf-fuel-mz-23/" title="Permalink to Improve Overall Performance With New Turf Fuel MZ-23" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/02/mz-23.featured-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="turf professionals" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/02/mz-23.featured-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/02/mz-23.featured-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/general-turf-care/improve-performance-new-turf-fuel-mz-23/" title="Permalink to Improve Overall Performance With New Turf Fuel MZ-23" rel="bookmark">Improve Overall Performance With New Turf Fuel MZ-23</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/e0cb2d5db565d00dc94117a808cbc578?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e0cb2d5db565d00dc94117a808cbc578?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/gclawnguest1/" title="View all posts by Guest Contributor">Guest Contributor</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/general-turf-care/improve-performance-new-turf-fuel-mz-23/" class="post-date" title="Permalink to Improve Overall Performance With New Turf Fuel MZ-23" rel="bookmark">February 13, 2019</a>
		</div>
	</div>

</article></li>					</ul>

				</div>
</li>
<li id="nav-menu-item-8087" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.turfmagazine.com/category/products/" class="menu-link main-menu-link"><span>Products</span></a><div class="sub-menu-container">					<ul class="sub-posts">
						<li class="col-sm-4"><article class="post-95084 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow plow" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">Meyer Products Super-V3 Snow Plow</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/dcantelmegroupc-com/" title="View all posts by Dominique Cantelme">Dominique Cantelme</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" class="post-date" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">March 12, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-95095 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="Turf Spring 2019 Issue" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/TURF-Spr19_EditLetter_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">Turf Spring 2019 Issue: Time For Renewal</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f82f7fc8048dfb859246b120ecf87b0e?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/anne-cosgrove/" title="View all posts by Anne Cosgrove">Anne Cosgrove</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/" class="post-date" title="Permalink to Turf Spring 2019 Issue: Time For Renewal" rel="bookmark">March 11, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-95059 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/lawn-care/21-0-dr-wood-chipper-shredder/" title="Permalink to 21.0 DR Wood Chipper Shredder" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/DR-Wood-21.0-Chipper-Shredder-feat-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="chipper shredder" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/DR-Wood-21.0-Chipper-Shredder-feat-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/DR-Wood-21.0-Chipper-Shredder-feat-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/lawn-care/21-0-dr-wood-chipper-shredder/" title="Permalink to 21.0 DR Wood Chipper Shredder" rel="bookmark">21.0 DR Wood Chipper Shredder</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/dcantelmegroupc-com/" title="View all posts by Dominique Cantelme">Dominique Cantelme</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/lawn-care/21-0-dr-wood-chipper-shredder/" class="post-date" title="Permalink to 21.0 DR Wood Chipper Shredder" rel="bookmark">March 7, 2019</a>
		</div>
	</div>

</article></li>					</ul>

				</div>
</li>
<li id="nav-menu-item-36395" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.turfmagazine.com/turf-design-build/" class="menu-link main-menu-link"><span>Turf Design Build</span></a></li>
<li id="nav-menu-item-78893" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.turfmagazine.com/tree-services/" class="menu-link main-menu-link"><span>Tree Services</span></a></li>
<li id="nav-menu-item-36396" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.turfmagazine.com/category/snow-ice-management/" class="menu-link main-menu-link"><span>Snow &#038; Ice Management</span></a><div class="sub-menu-container">					<ul class="sub-posts">
						<li class="col-sm-4"><article class="post-95084 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow plow" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">Meyer Products Super-V3 Snow Plow</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/dcantelmegroupc-com/" title="View all posts by Dominique Cantelme">Dominique Cantelme</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" class="post-date" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">March 12, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-95075 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow management professionals" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">Plowsite: This Week’s Cool Threads</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/mary-ellen-mccandless/" title="View all posts by Mary Ellen McCandless">Mary Ellen McCandless</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" class="post-date" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">March 5, 2019</a>
		</div>
	</div>

</article></li><li class="col-sm-4"><article class="post-94895 post-box post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/snow-ice-management/seven-steps-to-reducing-your-salt-use/" title="Permalink to Seven Steps To Reducing Your Salt Use" rel="bookmark">
							<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2019/02/salt-hero.featured-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="Reducing Salt Use" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/02/salt-hero.featured-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2019/02/salt-hero.featured-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<h3 class="title"><a href="https://www.turfmagazine.com/snow-ice-management/seven-steps-to-reducing-your-salt-use/" title="Permalink to Seven Steps To Reducing Your Salt Use" rel="bookmark">Seven Steps To Reducing Your Salt Use</a></h3>
		<div class="post-meta header-font">
						<img alt='' src='https://secure.gravatar.com/avatar/e0cb2d5db565d00dc94117a808cbc578?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e0cb2d5db565d00dc94117a808cbc578?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />			<a class="author-name" href="https://www.turfmagazine.com/author/gclawnguest1/" title="View all posts by Guest Contributor">Guest Contributor</a><span class="post-meta-separator">,</span>
			<a href="https://www.turfmagazine.com/snow-ice-management/seven-steps-to-reducing-your-salt-use/" class="post-date" title="Permalink to Seven Steps To Reducing Your Salt Use" rel="bookmark">February 1, 2019</a>
		</div>
	</div>

</article></li>					</ul>

				</div>
</li>
</ul></nav>							</div>
						</div>
					</div>
				</div>
				<!-- End Main Navigation Bar -->
<!-- /11506265/TF-SuperscapePlaceholder -->
<center>
<div id="div-gpt-ad-1467129242315-15">
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-15");
});
</script>
</div>
</center> 
<!-- /11506265/TF-Brandscape -->
<div id="div-gpt-ad-1467129242315-3" >
<script type="text/javascript">
googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-3");
});
</script>
</div>
<!-- /11506265/TF-Interstitial -->
<div id="div-gpt-ad-1467129242315-9" >
<script type="text/javascript">
 googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-9");
});
</script>
</div>
<center>
<!-- /11506265/TF-MobileAdhesion -->   
<div id="div-gpt-ad-1467129242315-14" >
      <script type="text/javascript">
        googletag.cmd.push(function() {
        googletag.display("div-gpt-ad-1467129242315-14");
        });
      </script>
    </div>
</center>
<div id="page-wrapper" class="container">

	<div class="row">
		<div id="page-content" class="col-sm-7 col-md-8">

			
														<article id="post-95084" class="post-95084 post type-post status-publish format-standard has-post-thumbnail hentry category-maintenance category-products category-snow-ice-management tag-meyer-products tag-plow tag-plow-forwards-and-backwards tag-plow-snow tag-remove-snow tag-snow-removal tag-super-v3 tag-v-plow">


<div class="tags clearfix">
							<a class="label " href="https://www.turfmagazine.com/category/maintenance/" title="View all posts in Maintenance" rel="category">Maintenance</a><a class="label " href="https://www.turfmagazine.com/category/products/" title="View all posts in Products" rel="category">Products</a><a class="label " href="https://www.turfmagazine.com/category/snow-ice-management/" title="View all posts in Snow &amp; Ice Management" rel="category">Snow &amp; Ice Management</a>						</div>

						<h1 class="post-title title title-large entry-title">Meyer Products Super-V3 Snow Plow</h1>

						
						<hr class="hr-thin-bottom">

						<div class="social-share">
	<span class="header-font">SHARE ON:</span>

		<a class="social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.turfmagazine.com%2Fsnow-ice-management%2Fmeyer-products-super-v3-snow-plow%2F&amp;t=Meyer Products Super-V3 Snow Plow" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a>
	
		<a class="social-twitter" href="https://twitter.com/home?status=Meyer Products Super-V3 Snow Plow https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a>
	
	
			<a class="social-pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.turfmagazine.com%2Fsnow-ice-management%2Fmeyer-products-super-v3-snow-plow%2F&amp;media=https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg&amp;description=Meyer Products Super-V3 Snow Plow" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a>
	
	
	
	
	
	
	</div>
						<div class="post-meta header-font">
	<a href="https://www.turfmagazine.com/author/dcantelmegroupc-com/" title="Posts by Dominique Cantelme" class="author url fn" rel="author">Dominique Cantelme</a>
		<span class="post-meta-separator">&mdash;</span> <a href="https://www.turfmagazine.com/snow-ice-management/meyer-products-super-v3-snow-plow/" class="post-date updated" title="Permalink to Meyer Products Super-V3 Snow Plow" rel="bookmark">March 12, 2019</a>
</div>
						
						<div class="post-content clearfix">
														<p>The all-new Meyer® Super-V3&#x2122; snow plow from <a href="https://www.meyerproducts.com/">Meyer Products</a> is made for ¾ ton and larger trucks and comes with a five year warranty. It is engineered with features designed to move more snow, faster and with more control. Users can choose from a V, scoop, or straight blade configuration with push-button ease thanks to a pistol grip controller and independently controlled wings.</p>
<p>The Super-V3 delivers industry-leading ground clearance; users do not have to worry about bottoming out and stacking capability is increased. In addition, Meyer’s exclusive Nite Saber® LED lights offer safer nighttime plowing with less draw on electrical systems.<br />
<a href="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg"><img class="alignright wp-image-95087" title="snow plow" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-300x196.jpg" alt="snow plow" width="252" height="165" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-300x196.jpg 300w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-768x502.jpg 768w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow-85x56.jpg 85w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3-Plow.jpg 780w" sizes="(max-width: 252px) 100vw, 252px" /></a><br />
The Super-V3 Plow features a pistol grip controller with self-diagnostics that reduces downtime and a Hands-Free Plowing (HFP) mode that lets users handle the shift lever to control the up/down movement of the blade. Dual-acting locking cylinders provide control, locking the blade position whether plowing forward or backward. Trip-edge moldboards absorb and dissipate the shock so users do not lose the entire load, or subject the truck, plow, and themselves to the full impact. Further, fleet friendly capability allows users to switch out theV3 snow plow with a Meyer straight blade.</p><div class="63p9s8sB" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><div class="insert-post-ads">
<!-- /24055536/TF-AfterFirstParagraph -->
<div id="div-gpt-ad-1467129242315-10" >
<script type="text/javascript">
 googletag.cmd.push(function(){
var TFAfterFirstParagraph = googletag.sizeMapping().
addSize([320, 1], 'fluid').
addSize([728, 1], 'fluid').
addSize([970, 1], 'fluid').
build();
window.slot10 = googletag.defineSlot("/24055536/TF-AfterFirstParagraph", [728, 30],
 "div-gpt-ad-1467129242315-10").defineSizeMapping(TFAfterFirstParagraph).addService(googletag.pubads())
.setCollapseEmptyDiv(true);
 googletag.enableServices();
googletag.display("div-gpt-ad-1467129242315-10");
});
</script>
</div>
</div></div>
<p><a href="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight.jpg"><img class="alignright wp-image-95091" src="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight-300x200.jpg" alt="snow plow" width="263" height="175" srcset="https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight-300x200.jpg 300w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight-768x512.jpg 768w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight-1024x683.jpg 1024w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight-85x57.jpg 85w, https://www.turfmagazine.com/wp-content/uploads/2019/03/Meyer-Products-Super-V3_straight.jpg 1200w" sizes="(max-width: 263px) 100vw, 263px" /></a>The Super-V3’s Standard Operating System has a streamlined appearance with an encased power unit and patented cable management system for reliable service. The hydraulic system also features an adjustable drop speed to handle various plowing conditions and meet operator preferences. Additionally, an exclusive upper-sealed center deflector keeps snow and ice off the windshield. On the bottom is an integrated urethane center cutting edge that eliminates snow trails left by ordinary V-plows.</p>
<p>Users can attach and detach the Super-V3 with a simple two-plug electrical attachment, and Meyer’s free-standing jack stand allows V3 height adjustment on uneven or shifting surfaces, making on/off easy in any condition.</p>
<p>All Meyer carbon steel moldboards are painted with Meyer Dura-Slick&#x2122; Paint. This automotive-style paint with Teflon® is baked on to the steel for durability and better snow-rolling action.</p>
<div class="tptn_counter" id="tptn_counter_95084">(Visited 1 times, 1 visits today)</div>						</div>

						
						<div class="post-tags clearfix">
<span class="post-tags-title header-font">Tags:</span>							<a class="label label-small label-light" href="https://www.turfmagazine.com/tag/meyer-products/" title="View all posts in Meyer Products" rel="category">Meyer Products</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/plow/" title="View all posts in Plow" rel="category">Plow</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/plow-forwards-and-backwards/" title="View all posts in plow forwards and backwards" rel="category">plow forwards and backwards</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/plow-snow/" title="View all posts in plow snow" rel="category">plow snow</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/remove-snow/" title="View all posts in remove snow" rel="category">remove snow</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/snow-removal/" title="View all posts in snow removal" rel="category">snow removal</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/super-v3/" title="View all posts in Super-V3" rel="category">Super-V3</a><a class="label label-small label-light" href="https://www.turfmagazine.com/tag/v-plow/" title="View all posts in v-plow" rel="category">v-plow</a>						</div>
						
					</article>
				
				
				<div class="post-nav section-container clearfix">
		
			<a class="post-previous" href="https://www.turfmagazine.com/from-the-editor/turf-spring-2019-issue-time-for-renewal/">
		<i class="icon-entypo-left-open-big"></i>
		<h3 class="title title-small">
			<span class="super-title">Previous post</span>
			Turf Spring 2019 Issue: Time For Renewal		</h3>
	</a>
	</div>
				<div class="about-author section-container clearfix vcard author">
	<img alt='Dominique Cantelme' src='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=200&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a411b229099a39714ccedcb893c18820?s=400&#038;d=mm&#038;r=g 2x' class='avatar avatar-200 photo' height='200' width='200' />
	<div class="about-author-info">
		<h3 class="author-name title title-medium">
			<span class="super-title">About the Author</span>
			<span class="fn">Dominique Cantelme</span>
		</h3>

		<div class="author-bio"></div>
		<div class="author-socials">
			
			
			
					</div>
	</div>
</div>
				<div class="post-related section-container clearfix">
	<h2 class="section-title">Related Posts</h2>
	<div class="row">
			<div class="post-box-wrapper col-sm-6 col-md-4 ">
			<article class="post-95075 post-box post-box-headline">

	<h3 class="title title-small"><a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">Plowsite: This Week’s Cool Threads</a></h3>
	<div class="post-meta header-font">
				<img alt='' src='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />		<a class="author-name" href="https://www.turfmagazine.com/author/mary-ellen-mccandless/" title="View all posts by Mary Ellen McCandless">Mary Ellen McCandless</a><span class="post-meta-separator">,</span>
		<a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" class="post-date" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">March 5, 2019</a>
	</div>
			<div class="post-thumbnail-wrapper vw-imgliquid">
			<a href="https://www.turfmagazine.com/business-management/plowsite-this-weeks-cool-threads-march-5-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">
				<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow management professionals" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>
		</div>
	
</article>		</div>
			<div class="post-box-wrapper col-sm-6 col-md-4 ">
			<article class="post-94866 post-box post-box-headline">

	<h3 class="title title-small"><a href="https://www.turfmagazine.com/plowsite/plowsite-weeks-cool-threads-january-29-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">Plowsite: This Week’s Cool Threads</a></h3>
	<div class="post-meta header-font">
				<img alt='' src='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />		<a class="author-name" href="https://www.turfmagazine.com/author/mary-ellen-mccandless/" title="View all posts by Mary Ellen McCandless">Mary Ellen McCandless</a><span class="post-meta-separator">,</span>
		<a href="https://www.turfmagazine.com/plowsite/plowsite-weeks-cool-threads-january-29-2019/" class="post-date" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">January 29, 2019</a>
	</div>
			<div class="post-thumbnail-wrapper vw-imgliquid">
			<a href="https://www.turfmagazine.com/plowsite/plowsite-weeks-cool-threads-january-29-2019/" title="Permalink to Plowsite: This Week’s Cool Threads" rel="bookmark">
				<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg" class="attachment-vw_small size-vw_small wp-post-image" alt="snow management professionals" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-360x200.jpeg 360w, https://www.turfmagazine.com/wp-content/uploads/2018/09/PlowSite_logo_gradient_770x500-265x147.jpeg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>
		</div>
	
</article>		</div>
			<div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm">
			<article class="post-94775 post-box post-box-headline">

	<h3 class="title title-small"><a href="https://www.turfmagazine.com/products/snow-debris-cleanup-easy-new-john-deere-angle-pickup-brooms/" title="Permalink to Snow, Debris Cleanup Easy With New John Deere Angle, Pickup Brooms" rel="bookmark">Snow, Debris Cleanup Easy With New John Deere Angle, Pickup Brooms</a></h3>
	<div class="post-meta header-font">
				<img alt='' src='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75eaae5153ba32ceacea53b90f47ca28?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />		<a class="author-name" href="https://www.turfmagazine.com/author/mary-ellen-mccandless/" title="View all posts by Mary Ellen McCandless">Mary Ellen McCandless</a><span class="post-meta-separator">,</span>
		<a href="https://www.turfmagazine.com/products/snow-debris-cleanup-easy-new-john-deere-angle-pickup-brooms/" class="post-date" title="Permalink to Snow, Debris Cleanup Easy With New John Deere Angle, Pickup Brooms" rel="bookmark">December 19, 2018</a>
	</div>
			<div class="post-thumbnail-wrapper vw-imgliquid">
			<a href="https://www.turfmagazine.com/products/snow-debris-cleanup-easy-new-john-deere-angle-pickup-brooms/" title="Permalink to Snow, Debris Cleanup Easy With New John Deere Angle, Pickup Brooms" rel="bookmark">
				<img width="360" height="200" src="https://www.turfmagazine.com/wp-content/uploads/2018/12/JD_AngleBroom-360x200.jpg" class="attachment-vw_small size-vw_small wp-post-image" alt="angle and pickup brooms" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/12/JD_AngleBroom-360x200.jpg 360w, https://www.turfmagazine.com/wp-content/uploads/2018/12/JD_AngleBroom-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" />			</a>
		</div>
	
</article>		</div>
		</div>
</div>

				
<div id="disqus_thread"></div>

					</div>

		<aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4">
			<div class="sidebar-inner">
<div id="search-5" class="widget vw-sidebar-custom-Content-Sidebar widget_search"><form action="https://www.turfmagazine.com/" id="searchform" class="searchform" method="get">
	<input type="text" id="s" name="s" value="Search" onfocus="if(this.value=='Search')this.value='';" onblur="if(this.value=='')this.value='Search';" autocomplete="off" />
	<button class="search-button"><i class="icon-entypo-search"></i></button>
</form></div><div id="text-20" class="widget vw-sidebar-custom-Content-Sidebar widget_text">			<div class="textwidget"><!-- /11506265/TF-Right1 -->
<center>
<div id="div-gpt-ad-1467129242315-5" >
<script type="text/javascript">
 googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-5");
});
</script>
</div>
</center></div>
		</div><div id="execphp-3" class="widget vw-sidebar-custom-Content-Sidebar widget_execphp">			<div class="execphpwidget"></div>
		</div><div id="vw_widget_latest_category-6" class="widget vw-sidebar-custom-Content-Sidebar widget_vw_widget_latest_category"><h3 class="widget-title">Sponsored Content</h3><div class="post-box-list"><article class="post-78347 post-box fly-in animated-content post-box-large-thumbnail">
			<div class="post-thumbnail-wrapper">
			
						<a href="https://www.turfmagazine.com/jobber/mil-spec-lawn-care-success-story/" title="Permalink to How Two Military Veterans Built A Successful Business In One Season" rel="bookmark">
							<img width="750" height="420" src="https://www.turfmagazine.com/wp-content/uploads/2018/01/jobber-mil-spec-feature-1140-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="MIL-Spec Lawn Care" srcset="https://www.turfmagazine.com/wp-content/uploads/2018/01/jobber-mil-spec-feature-1140-750x420.jpg 750w, https://www.turfmagazine.com/wp-content/uploads/2018/01/jobber-mil-spec-feature-1140-300x169.jpg 300w, https://www.turfmagazine.com/wp-content/uploads/2018/01/jobber-mil-spec-feature-1140-265x147.jpg 265w, https://www.turfmagazine.com/wp-content/uploads/2018/01/jobber-mil-spec-feature-1140-85x48.jpg 85w" sizes="(max-width: 750px) 100vw, 750px" />			</a>

		</div>
		
	<div class="post-box-inner">
				
		<div class="post-categories clearfix">
			<div class="label label-light label-small" title="Video Post"><i class="icon-entypo-play"></i></div><a class="label label-small" href="https://www.turfmagazine.com/category/jobber/" title="View all posts in Jobber" rel="category">Jobber</a>		</div>
		
		<h3 class="title"><a href="https://www.turfmagazine.com/jobber/mil-spec-lawn-care-success-story/" title="Permalink to How Two Military Veterans Built A Successful Business In One Season" rel="bookmark">How Two Military Veterans Built A Successful Business In One Season</a></h3>
		<div class="post-meta header-font">
									<a class="author-name" href="https://www.turfmagazine.com/author/jobber/" title="View all posts by Sponsored By Jobber">Sponsored By Jobber</a>		</div>
		
		<div class="post-excerpt "><p>Brian and Kristy Boase, owners of MIL-SPEC Lawn Care, have found overwhelming success in their first year of business.</p>
</div>
		<div class="post-box-footer clearfix">
					</div>
	</div>

</article></div></div><div id="custom_html-2" class="widget_text widget vw-sidebar-custom-Content-Sidebar widget_custom_html"><div class="textwidget custom-html-widget"><center><a class="twitter-timeline" data-width="300" data-height="500" data-link-color="#586a54" href="https://twitter.com/TurfMagazine?ref_src=twsrc%5Etfw">Tweets by TurfMagazine</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></center>
<br>
<!-- /11506265/TF-Right2 -->
<center>
<div id="div-gpt-ad-1467129242315-6" >
<script type="text/javascript">
 googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-6");
});
</script>
</div>
</center></div></div><div id="widget_tptn_pop-4" class="widget vw-sidebar-custom-Content-Sidebar tptn_posts_list_widget"><h3 class="widget-title">Trending Now</h3><div class="tptn_posts  tptn_posts_widget tptn_posts_widget4"><ul><li><a href="https://www.turfmagazine.com/maintenance/trimming-and-edging-the-right-way/"     class="tptn_link"><img src="https://www.turfmagazine.com/wp-content/uploads/2015/01/A10687_1_full-85x85.jpg" alt="Trimming and Edging the Right Way" title="Trimming and Edging the Right Way" width="85" height="85" class="tptn_thumb tptn_featured" /></a><span class="tptn_after_thumb"><a href="https://www.turfmagazine.com/maintenance/trimming-and-edging-the-right-way/"     class="tptn_link"><span class="tptn_title">Trimming and Edging the Right Way</span></a></span></li><li><a href="https://www.turfmagazine.com/lawn-care/5-tips-to-enhance-broadleaf-weed-control/"     class="tptn_link"><img src="https://www.turfmagazine.com/wp-content/uploads/2015/01/A10040_1_full-85x85.jpg" alt="5 Tips To Enhance Broadleaf Weed Control" title="5 Tips To Enhance Broadleaf Weed Control" width="85" height="85" class="tptn_thumb tptn_featured" /></a><span class="tptn_after_thumb"><a href="https://www.turfmagazine.com/lawn-care/5-tips-to-enhance-broadleaf-weed-control/"     class="tptn_link"><span class="tptn_title">5 Tips To Enhance Broadleaf Weed Control</span></a></span></li><li><a href="https://www.turfmagazine.com/product-design/righteously-upright/"     class="tptn_link"><img src="https://www.turfmagazine.com/wp-content/uploads/2016/01/righteously-upright-96x96.jpg" alt="Our Guide To Stand-On Commercial Mowers" title="Our Guide To Stand-On Commercial Mowers" width="85" height="85" class="tptn_thumb tptn_featured" /></a><span class="tptn_after_thumb"><a href="https://www.turfmagazine.com/product-design/righteously-upright/"     class="tptn_link"><span class="tptn_title">Our Guide To Stand-On Commercial Mowers</span></a></span></li><li><a href="https://www.turfmagazine.com/viewpoints/what-comes-first-mow-edge-or-weed/"     class="tptn_link"><img src="https://www.turfmagazine.com/wp-content/uploads/2014/08/web-iStock-92702072-85x85.jpg" alt="What Comes First: Mow, Edge or Weed?" title="What Comes First: Mow, Edge or Weed?" width="85" height="85" class="tptn_thumb tptn_featured" /></a><span class="tptn_after_thumb"><a href="https://www.turfmagazine.com/viewpoints/what-comes-first-mow-edge-or-weed/"     class="tptn_link"><span class="tptn_title">What Comes First: Mow, Edge or Weed?</span></a></span></li><li><a href="https://www.turfmagazine.com/product-design/engine-manufacturers-commercial-mowing-market/"     class="tptn_link"><img src="https://www.turfmagazine.com/wp-content/uploads/2017/01/2018-EngineBattleMainImage-96x96.jpg" alt="2018 Competitive Commercial Engine Market Spurs Innovation" title="2018 Competitive Commercial Engine Market Spurs Innovation" width="85" height="85" class="tptn_thumb tptn_featured" /></a><span class="tptn_after_thumb"><a href="https://www.turfmagazine.com/product-design/engine-manufacturers-commercial-mowing-market/"     class="tptn_link"><span class="tptn_title">2018 Competitive Commercial Engine Market Spurs Innovation</span></a></span></li></ul><div class="tptn_clear"></div></div></div><div id="text-23" class="widget vw-sidebar-custom-Content-Sidebar widget_text">			<div class="textwidget"><!-- /11506265/TF-Right3 -->
<center>
<div id="div-gpt-ad-1467129242315-7" >
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-7");
});
</script>
</div>
</center></div>
		</div><div id="text-27" class="widget vw-sidebar-custom-Content-Sidebar widget_text">			<div class="textwidget"><!-- /11506265/TF-Right4 -->
<center>
<div id="div-gpt-ad-1467129242315-8" >
<script type="text/javascript">
 googletag.cmd.push(function(){
googletag.display("div-gpt-ad-1467129242315-8");
});
</script>
</div>
</center></div>
		</div></div>		</aside>
	</div>
</div>

<!-- /24055536/TF-AboveFooter -->
<center>
<div id="div-gpt-ad-1467129242315-0" >
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.display("div-gpt-ad-1467129242315-0");
});
</script>
</div>
</center>
<br>				
<footer id="footer">
					<div class="footer-sidebar">
	<div class="container">
		<div class="row">
							<div class="footer-sidebar-1 widget-area col-sm-4" role="complementary">
				<div id="text-16" class="widget vw-sidebar-footer-1 widget_text">			<div class="textwidget"><h3 class="widget-title" >Our Sites</h3>
<a title="" href="https://facilityexecutive.com/topics/" target="_blank">Facility Executive</a> <br> <a title="" href="https://www.lawnsite.com/" target="_blank">LawnSite Forums</a>  <br> <a title="" href="https://www.plowsite.com/" target="_blank">PlowSite Forums</a>  <br> <a title="" href="https://www.turfmagazine.com/turf-design-build/" >Turf Design Build</a>  <br> <a title="" href="https://www.turfmagazine.com/tree-services/" >Tree Services</a>
<br></div>
		</div>				</div>
			
							<div class="footer-sidebar-2 widget-area col-sm-4" role="complementary">
				<div id="text-8" class="widget vw-sidebar-footer-2 widget_text">			<div class="textwidget"><!-- /11506265/TF-CenterFooter -->
<div id="div-gpt-ad-1465997482933-2" >
<script type="text/javascript">
 googletag.cmd.push(function(){
var TFCenterFooter = googletag.sizeMapping().
 addSize([320, 1], [[1, 1], [300, 250]]).
 addSize([728, 1], [[1, 1], [300, 250]]).
 addSize([970, 1], [[1, 1], [300, 250]]).
 build();
window.slot2 = googletag.defineSlot("/11506265/TF-CenterFooter", [300, 250],
 "div-gpt-ad-1465997482933-2").defineSizeMapping(TFCenterFooter).addService(googletag.pubads())
.setCollapseEmptyDiv(true);
 googletag.enableServices();
googletag.display("div-gpt-ad-1465997482933-2");
});
</script>
</div></div>
		</div>				</div>
			
					</div>
	</div>
</div>
					<div class="copyright">
						<div class="container">
							<div class="row">
								<div class="col-sm-6 copyright-left">Copyright 2018 Group C Media. All rights reserved. | <a title="About Us" href="/about-us" >About Us</a> | <a title="Advertise" href="http://www.123formbuilder.com/form-3795317/LawnSite-Media-Kit-Request-Form" >Advertise</a> | <a title="Reprints" href="/reprints" >Reprints</a> | <a title="Privacy" href="http://www.groupc.com/privacy-policy-2/" >Privacy</a></div>
								<div class="col-sm-6 copyright-right">
									<a class="back-to-top" href="#top">&uarr;	Back to top</a>
								</div>
							</div>
						</div>
					</div>


				</footer>
				
			</div> <!-- Off canvas body inner -->
		
		<script>jQuery(document).ready(function ($) { $('p').selectionSharer();});</script><script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/comment-reply.min.js?ver=4.9.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"turfmagazine"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"95084 https:\/\/www.turfmagazine.com\/?p=95084","disqusShortname":"turfmagazine","disqusTitle":"Meyer Products Super-V3 Snow Plow","disqusUrl":"https:\/\/www.turfmagazine.com\/snow-ice-management\/meyer-products-super-v3-snow-plow\/","postId":"95084"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/ui/effect-fade.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/presso-shortcodes/js/presso-shortcodes.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/js/jquery.fitvids.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/js/jquery.isotope.min.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/flexslider/jquery.flexslider.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/framework/swipebox/jquery.swipebox.min.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/js/asset.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/presso2-0/js/main.js?ver=1.1%20tacOcat'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/themes/tacocat/js/gallery-frontend.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='https://www.turfmagazine.com/wp-content/plugins/selection-sharer/js/selection-sharer.js?ver=0.1'></script>
		<script type='text/javascript'>
			;(function( $, window, document, undefined ){
				"use strict";

				$( document ).ready( function ($) {
							$( '.flexslider' ).flexslider({
			animation: "fade",
			easing: "easeInCirc",
			slideshow: true,
			slideshowSpeed: 4000,
			animationSpeed: 600,
			randomize: false,
			pauseOnHover: true,
			prevText: '',
			nextText: '',
			start: function( slider ) {
				slider.css( 'opacity', '1' );
				slider.find( '.post-thumbnail-wrapper' ).css( 'height', '500px' ).imgLiquid().fadeIn(250);
			},
		});
					} );
				
			})( jQuery, window , document );

					</script>
		        <script>
jQuery(document).ready(function(){
        jQuery("#page-content .post-content div").css("margin-bottom", "0");
        jQuery("#page-content .post-content div div").css("margin-bottom", "10px");
    });
</script>
        
<!-- Begin Constant Contact Active Forms -->
	<script> var _ctct_m = "1a559650390e455f01bfb05150f2e1f5"; </script>
	<script id="signupScript" src="//static.ctctcdn.com/js/signup-form-widget/current/signup-form-widget.min.js" async defer></script>
<!-- End Constant Contact Active Forms —>

	</body>
</html>